Loading
logo
Welcome Guest! To enable all features please Login or Register.

Notification

Icon
Error

MichaelMorin
#1 Posted : Tuesday, February 6, 2018 5:46:00 PM(UTC)
MichaelMorin

Rank: Newbie

Groups: Registered
Joined: 2/2/2018(UTC)
Posts: 1

Hello,

we have deployed our application in production and some times we face the issue of http server variables getting null values in http request object and the application crashes, we formulate xml for all server variables and send across to database for logging, the xml we get consists of all server variables and once server variables get null value it gives incomplete xml object.

The server variables we get as null values are CurrentHttpRequest.ServerVariables["HTTP_USER_AGENT"]
CurrentHttpRequest.ServerVariables["HTTP_ACCEPT"] and CurrentHttpRequest.ServerVariables["HTTP_ACCEPT_ENCODING"]


Can some one let me know which scenario the server variables gets null values , this issue is intermittent most of the time the server varible values are getting proper values and sometimes only null values coming from server variables,

It would be great if some one propose a solution for this issue as http request comes from browser.

Please Help.

Thanks !

I didn't find the right solution from the internet.

References:

http://forums.tutorialized.com/asp-net-81/

Corporate Advertising Examples

Edited by user Wednesday, February 7, 2018 12:04:34 PM(UTC)  | Reason: Not specified

Sponsor
Users browsing this topic
Guest (2)
You cannot post new topics in this forum.
You cannot reply to topics in this forum.
You cannot delete your posts in this forum.
You cannot edit your posts in this forum.
You cannot create polls in this forum.
You cannot vote in polls in this forum.

Powered by YAF | YAF © 2003-2018, Yet Another Forum.NET
This page was generated in 0.100 seconds.